Plesk Login Issues
Incident Report for Primed Hosting
Resolved
This incident has been resolved.
Posted Sep 19, 2020 - 11:00 EDT
Identified
We are aware of an issue where users are unable to login to their plesk accounts. We will keep you updated once we have more info.
Posted Sep 19, 2020 - 10:46 EDT
This incident affected: Panels (Plesk Panel).