Account Creation Issues
Incident Report for Primed Hosting
Resolved
This incident has been resolved.
Posted May 24, 2020 - 21:59 EDT
Investigating
We are aware of an issue where when purchasing services and the payment is done the system does not create the account for the services. We are looking into it and will keep you updated! If you purchased services we will be able to add it manually please reach out to us on our discord server. https://primedhosting.com/discord
Posted May 24, 2020 - 21:46 EDT
This incident affected: Core Services (Billing System).