Billing system issues
Incident Report for Primed Hosting
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 10:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2020 - 09:58 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2020 - 09:32 EDT
Investigating
Users may experience a delay in service activation. We are experiencing some issues on our backend of our billing system. We are looking into the issue and will keep you all updated once we have more info.
Posted Sep 30, 2020 - 08:44 EDT
This incident affected: Core Services (Billing System).