Credit Card Payment Issues
Incident Report for Primed Hosting
Resolved
We've made a change in our theme for right now for everyone to make payments on cards. We apologize for the inconvenience.
Posted Aug 01, 2021 - 17:14 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 01, 2021 - 10:20 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 31, 2021 - 19:59 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2021 - 08:51 EDT
Update
We are still waiting on a response from our vendor. We apologize this is taking longer then expected.
Posted Jul 30, 2021 - 16:27 EDT
Update
We are continuing to investigate this issue.
Posted Jul 30, 2021 - 12:42 EDT
Investigating
We are aware of some users having issues trying to pay things with their credit/debit card. We are investigating the issue and have reached out to our Vendors
Posted Jul 30, 2021 - 11:37 EDT
This incident affected: Core Services (Website) and 3rd Party Services (Stripe Checkout.js).